Treehouse : sound, browsers & platforms - Treehouse

Jump to content

Hide message Show message
Welcome to Treehouse !

Join us now to get access to all our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, get your own private messenger and more.

Support the Sites!


Icon Registration for the Forums

Unfortunately, due to an unreasonable amount of obscene and/or dangerous data being posted by spambots registering for the forums, we have had to disable the automatic registration process. For those wishing to manually register, we ask that you contact the author of Memories from the email provided on his stories, and he will work with you to set up an account manually. Note that he will verify that you are authentic before beginning the process, for the safety of all board members.


Page 1 of 1

sound, browsers & platforms


#1 User is online   Silver Wolf 

  • Root
  • PipPipPipPipPipPip
  • Group: Members
  • Posts: 675
  • Joined: 21-January 11
  • Location:Montreal

Posted 07 March 2011 - 02:32 PM

I have been informed by 4 totally independent sources that sound tracks that come with my story do not play on certain OS/browser combinations.

The most direct test of this is to click on the Silver Wolf Icon at wolf's nest
NORMALLY, there should be a wolf howl as this bit of code indicates:

<object type="audio/mpeg" data="Cave_Lupus/Files/wolf-howl.mp3" width="200"height="20"> <param name="src" value="Cave_Lupus/Files/wolf-howl.mp3"> <param name="autoplay" value="true"> <param name="autoStart" value="1"> alt : <a href="Cave_Lupus/Files/wolf-howl.mp3">Wolf Howl</a> </object> This is in conformity with W3C standards, where the use of Microsoft's 'embed' token is strongly discouraged as being proprietary.I ran tests with the following combos:XP/IE7XP/FirefoxXP emulator on VMWare IMac /IE7XP emulator on VMWare IMac / FirefoxVista/IE7Vista/FirefoxImac OS 10.5 Leopard/SafariImac OS 10.6 Snow Leopard/SafariIMac OS 10.5 Leopard/FirefoxAll of the above take the 'object' and render it properlyNo tests were done on Geiko or Opera.FAILED: all tests done with Windows 7/IE8What I need is:tests done with IE7 or firefox (mozila) on Windows 7tests done with Geiko or Opera on any platform.Suggestions as to what to do to deal with the issue. Quite frankly, I'm getting pretty frustrated. I'm hoping to kick Microsoft in the nuts to make them fix that. There's no reason why something that worked should fail when you update.As many reports of this anomaly as possible with Windows 7. The bigger it becomes, the more likely they will ship a patch out.
Thank you.Christian









#2 User is online   Silver Wolf 

  • Root
  • PipPipPipPipPipPip
  • Group: Members
  • Posts: 675
  • Joined: 21-January 11
  • Location:Montreal

Posted 07 March 2011 - 07:35 PM

I got an email from Micro$oft and it wanted Money for the help in fixing THEIR issue... It pissed me off, as you can imagine. I find it outrageous they dare ask customers to pay for their own crap. I just hope W3C is a bit more user-friendly. Pray for Micro$soft's demise!


#3 User is offline   Cynaira 

  • Treehouse Mama
  • PipPipPipPipPipPip
  • Group: Author
  • Posts: 710
  • Joined: 19-January 11
  • Location:Eastern Time Zone

Posted 07 March 2011 - 07:57 PM

Can just shake my head and think, yep, that sounds about right, which is unfortunate.
"The heart was truly meant to be a little wild, a little free"

"Whatever happens, the future is the only way back." "Back to where we belong forever. The future is the one path out of time into eternity." From 'Breathless' by Dean Koontz

“There is in every true woman's heart a spark of heavenly fire, which lies dormant in the broad daylight of prosperity; but which kindles up, and beams and blazes in the dark hour of adversity.”
—Washington Irving, The Sketch Book, 1820


#4 User is offline   robuntu 

  • Branch
  • PipPipPipPip
  • Group: Members
  • Posts: 104
  • Joined: 25-February 11
  • Location:Just North of North Dallas near Plano

Posted 07 March 2011 - 09:05 PM

View PostSilver Wolf, on 07 March 2011 - 02:32 PM, said:

I have been informed by 4 totally independent sources that sound tracks that come with my story do not play on certain OS/browser combinations.

The most direct test of this is to click on the Silver Wolf Icon at wolf's nest
NORMALLY, there should be a wolf howl as this bit of code indicates:

<object type="audio/mpeg" data="Cave_Lupus/Files/wolf-howl.mp3" width="200"height="20"> <param name="src" value="Cave_Lupus/Files/wolf-howl.mp3"> <param name="autoplay" value="true"> <param name="autoStart" value="1"> alt : <a href="Cave_Lupus/Files/wolf-howl.mp3">Wolf Howl</a> </object> This is in conformity with W3C standards, where the use of Microsoft's 'embed' token is strongly discouraged as being proprietary.I ran tests with the following combos:XP/IE7XP/FirefoxXP emulator on VMWare IMac /IE7XP emulator on VMWare IMac / FirefoxVista/IE7Vista/FirefoxImac OS 10.5 Leopard/SafariImac OS 10.6 Snow Leopard/SafariIMac OS 10.5 Leopard/FirefoxAll of the above take the 'object' and render it properlyNo tests were done on Geiko or Opera.FAILED: all tests done with Windows 7/IE8What I need is:tests done with IE7 or firefox (mozila) on Windows 7tests done with Geiko or Opera on any platform.Suggestions as to what to do to deal with the issue. Quite frankly, I'm getting pretty frustrated. I'm hoping to kick Microsoft in the nuts to make them fix that. There's no reason why something that worked should fail when you update.As many reports of this anomaly as possible with Windows 7. The bigger it becomes, the more likely they will ship a patch out. Thank you.Christian

FYI: Works just fine with Firefox 3.6.14 In Ubuntu 10.10. I think I had the volume turned up a little though... Sent a familiar cold chill up my spine..Also, my neighbor, a retired Gunny Sgt, came flying out his door and was looking around, weird..

Robby

Linux Mint 13 Maya (Mate)

On a world without fences and walls, who needs Gates and Windows.



#5 User is online   Silver Wolf 

  • Root
  • PipPipPipPipPipPip
  • Group: Members
  • Posts: 675
  • Joined: 21-January 11
  • Location:Montreal

Posted 07 March 2011 - 11:45 PM

View Postrobuntu, on 07 March 2011 - 09:05 PM, said:

FYI: Works just fine with Firefox 3.6.14 In Ubuntu 10.10. I think I had the volume turned up a little though... Sent a familiar cold chill up my spine..Also, my neighbor, a retired Gunny Sgt, came flying out his door and was looking around, weird..


Thsnks for the information...
I also have someone saying XP/IE8 doesn't work... so the issue seems focussed on IE8... I wish I understood why... after all mp3 is a standard for music on internet... and should not need any assist to run things...



#6 User is offline   Cynaira 

  • Treehouse Mama
  • PipPipPipPipPipPip
  • Group: Author
  • Posts: 710
  • Joined: 19-January 11
  • Location:Eastern Time Zone

Posted 08 March 2011 - 12:50 AM

Hi Silver Wolf, I just took a moment to see if it worked here. It worked fine for me. Both on IE8 (after I clicked for ActiveX to work when I opened the page) and on Firefox 3.6.15. I have Windows 7 here. Just thought I would let know.
"The heart was truly meant to be a little wild, a little free"

"Whatever happens, the future is the only way back." "Back to where we belong forever. The future is the one path out of time into eternity." From 'Breathless' by Dean Koontz

“There is in every true woman's heart a spark of heavenly fire, which lies dormant in the broad daylight of prosperity; but which kindles up, and beams and blazes in the dark hour of adversity.”
—Washington Irving, The Sketch Book, 1820


#7 User is offline   Shark Bait 

  • Wave Master
  • PipPipPip
  • Group: Author
  • Posts: 57
  • Joined: 16-January 11
  • Location:Secret undersea bunker

Posted 08 March 2011 - 06:35 AM

works fine on opera..xp
dunno why anyone uses msie anyways

Posted Image Posted Image Posted Image
This isn't me by the way...I'ts John John Florence, my idol...just wanted to make that clear!


#8 User is offline   robuntu 

  • Branch
  • PipPipPipPip
  • Group: Members
  • Posts: 104
  • Joined: 25-February 11
  • Location:Just North of North Dallas near Plano

Posted 08 March 2011 - 12:38 PM

View Postrobuntu, on 07 March 2011 - 09:05 PM, said:

FYI: Works just fine with Firefox 3.6.14 In Ubuntu 10.10. I think I had the volume turned up a little though... Sent a familiar cold chill up my spine..Also, my neighbor, a retired Gunny Sgt, came flying out his door and was looking around, weird..


With my weekly application and security update came firefox 3.6.15 and it also checked out fine.

Robby

Linux Mint 13 Maya (Mate)

On a world without fences and walls, who needs Gates and Windows.



#9 User is offline   MotherHusky 

  • Trunk
  • PipPipPipPipPip
  • Group: Members
  • Posts: 229
  • Joined: 04-February 11
  • Location:Western New York

Posted 08 March 2011 - 10:17 PM

I just tried it myself, using Firefox 3.6.14 and the NoScript plug-in on XP. Even after I allowed your host domain full script privileges, there was NO sound. I know that sound on the web works in my configuration, as I have to keep Tickie blocked to keep it quiet. And the sound works fine on all those "Tube" web sites, if you know what I mean...:rolleyes:


#10 User is online   Silver Wolf 

  • Root
  • PipPipPipPipPipPip
  • Group: Members
  • Posts: 675
  • Joined: 21-January 11
  • Location:Montreal

Posted 08 March 2011 - 10:50 PM

It's sad internet browsers can not implement this simple code in a standard way. mp3 is the nitty gritty of sound and the &lt object &gt is the w3c convention. :(


#11 User is online   Silver Wolf 

  • Root
  • PipPipPipPipPipPip
  • Group: Members
  • Posts: 675
  • Joined: 21-January 11
  • Location:Montreal

Posted 10 March 2011 - 06:56 PM

Just so I know, has anyone tried IE 9 with my page? I don't expect it to work, but who knows, maybe Microsoft woke up from its beauty sleep...


#12 User is offline   Gracey 

  • Official Wallaby
  • Pip
  • Group: Members
  • Posts: 13
  • Joined: 20-January 11
  • Location:Melbourne, Australia

Posted 11 March 2011 - 03:18 AM

Deathly silence until I clicked on "alt Howl" and manually started the unearthly sound



#13 User is online   Silver Wolf 

  • Root
  • PipPipPipPipPipPip
  • Group: Members
  • Posts: 675
  • Joined: 21-January 11
  • Location:Montreal

Posted 11 March 2011 - 06:56 PM

Unearthly? My love call unearthly??? says Silver Wolf...

Page 1 of 1


Fast Reply

This post will need approval from a moderator before this post is shown.
  

Enter your sign in name and password


Sign in options